View Issue Details

IDCategoryLast Update
0001982Bug Report2019-08-26 23:01
ReporterCmdrKeen 
SeveritytweakReproducibilityN/A
Status closedResolutionfixed
Summary0001982: Kevin re-appearing with apron and pot
DescriptionAfter finding a replacement doing his cafeteria duty, he appears in the cafeteria without apron and pot.
Still, if you use the option about the "panties" for Master Samrok and he tells you it is not so bad... he wears the apron again and has the pot in hand. The picture stays until leaving the dialogue with him.
Platform/OSWindows
Version0.18.6

Activities

Casiope

Casiope

2019-06-10 14:31

reporter   ~0002781

Version 0.18.6. See attachment.

Steps to reproduce:
1. Meet Master Somrak at the gym.
2. Meet Kevin in the cafeteria.
3. Convince Erik to replace Kevin for the cafeteria duty.
4. Tell the news to Kevin.
5. Kevin removes his apron.
6. Talk to Kevin again.
7. Choose the "Used panties" dialogue option.

Issues:
• During the conversation, Kevin puts his old apron on.
• He keeps his apron after the conversation.

Solution:
• Kevin should not put his apron on during the conversation.

Kevin's apron.jpg (563,099 bytes)
Casiope

Casiope

2019-06-10 16:12

reporter   ~0002782

/!\ Don't correct this bug alone because there is another bug. Review and test both Kevin's dialogues AND Kevin's outfits inside the cafeteria. If you don't do this, the script will call an image that may not exist, leading to an exception.
For this bug report ONLY, the problem is in script "locations\school\second_floor\cafeteria\dialogues", line 152:

$ M_kevin.outfit.set_default_outfit_schedule([["gym", "apron", "apron", "apron"]])
-->
$ M_kevin.outfit.set_default_outfit_schedule([["gym", "gym", "gym", "gym"]])

When Kevin has been replaced, he's supposed to stop working at the cafeteria, thus wearing the gym outfit all day. He will stay at this location only in afternoon, during the weekdays. The "object" Kevin displays this change correctly, not the "character" Kevin.
ebinfo

ebinfo

2019-06-10 22:17

reporter   ~0002784

i reported that one as well see 0001802
Casiope

Casiope

2019-06-11 13:30

reporter   ~0002789

Related to bug report 0001989.
Morbooze

Morbooze

2019-08-26 23:01

updater   ~0002952

Fixed for 0.19. Reopen it if you notice the problem again.

Issue History

Date Modified Username Field Change
2019-06-10 13:09 CmdrKeen New Issue
2019-06-10 14:31 Casiope File Added: Kevin's apron.jpg
2019-06-10 14:31 Casiope Note Added: 0002781
2019-06-10 16:12 Casiope Note Added: 0002782
2019-06-10 22:17 ebinfo Note Added: 0002784
2019-06-11 13:30 Casiope Note Added: 0002789
2019-08-26 23:01 Morbooze Status new => closed
2019-08-26 23:01 Morbooze Resolution open => fixed
2019-08-26 23:01 Morbooze Note Added: 0002952