View Issue Details

IDCategoryLast Update
0001989Bug Report2019-08-26 23:00
ReporterDarkKuno 
SeveritytweakReproducibilityalways
Status closedResolutionfixed
Summary0001989: Inconsistencies with Kevin dialogue regarding a replacement for him on cafeteria duty
DescriptionAfter having the initial conversation with Kevin about finding someone to replace him so he can help you train in the Gym, It's possible to talk to Erik about replacing Kevin on cafeteria duty, obtaining the Sea Dogs game for him, and Erik agreeing to do it without going through the return discussion tree with Kevin about "Someone to cover".

If you give Erik the game and get him to agree on a weekday afternoon while in the cafeteria, then try to talk to Kevin as well, you will get stuck in a loop of Kevin asking whether you've talked to Erik and the MC saying he hasn't yet, even though you've already given Erik the game and gotten him to agree to replace Kevin.

Fortunately, exiting the Cafeteria and re-entering will trigger the automatic dialogue prompt regarding whether you've found someone to replace him, allowing you to unlock him for Strength training moving forward.

However, it can still be confusing and feels a bit silly.
Platform/OSWindows
Version0.18.6

Activities

Casiope

Casiope

2019-06-11 13:12

reporter   ~0002787

Related to bug report 0001982.
Casiope

Casiope

2019-06-11 13:28

reporter   ~0002788

I was explaining, in bug report 1982, that the part with the cafeteria duty, Kevin and Erik, has to be redone because it contains too many bugs in outfits, dialogues and the way the quest is presented to the players. I took one hour yesterday trying to figure where are the bugs, but I came with the conclusion that they can't be fixed by adding a few lines of code.

Currently, Erik wears the apron when Kevin still have the dialogue choice in which he removes his apron. And this conversation can be repeated until the next day because the two events are not synchronized. It seems to me that the developers have done something complicated, where it could be much more linear and simple:

Talk to Kevin (with apron) about the weightlifting -> Talk to Erik (without apron) about cafeteria duty -> Buy the game -> Give it to Erik (without apron) -> Talk to Kevin (with apron) about the replacement -> Kevin removes the apron -> Kevin now appears without apron/Erik now appears with apron
Morbooze

Morbooze

2019-08-26 23:00

updater   ~0002951

Fixed for 0.19. Reopen it if you notice the problem again.

Issue History

Date Modified Username Field Change
2019-06-11 03:16 DarkKuno New Issue
2019-06-11 13:12 Casiope Note Added: 0002787
2019-06-11 13:28 Casiope Note Added: 0002788
2019-08-26 23:00 Morbooze Status new => closed
2019-08-26 23:00 Morbooze Resolution open => fixed
2019-08-26 23:00 Morbooze Note Added: 0002951