View Issue Details

IDCategoryLast Update
0000189Bug Report2018-11-28 04:09
Reporterdipset12 
SeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed
Summary0000189: karaoke bug with eve
Descriptionthe karaoke is never ending
Platform/OSOSX
Version0.15

Relationships

related to 0000423 closed Karaoke is in endless loop. no fail, no progress, no success 

Activities

GreenCap

GreenCap

2018-04-16 21:18

updater   ~0000359

By neverending do you mean you have to keep playing it over and over and you get the failure cutscene each time or that the minigame itself continues forever?
thaisi

thaisi

2018-05-01 21:38

reporter   ~0000451

I have the same issue. The minigame itself continues forever. No failure, no success, no way to stop it.

I am also using OSX
thaisi

thaisi

2018-05-01 21:43

reporter   ~0000452

I am using version 15.3 BTW. (I see all kind of reports that stuff was fixed in 15.2)
thaisi

thaisi

2018-05-03 17:16

reporter   ~0000455

Is there any way I can provide more info on this? because I can not progress in the game anymore. Do you want a video of it?
any "debug" info I could gather? for me it is 100% reproducible.
dogeek

dogeek

2018-06-06 22:54

developer   ~0000477

Provide steps on how to reproduce. If you can unpack the game code, and print a log of all the variables in the class GuitarHeroMinigame that should help quite a lot. print the state of mrs dewitt's FSM. Have you a patch installed on the game ?
dogeek

dogeek

2018-06-06 23:01

developer   ~0000478

this file should help you print the necessary information to the console.

debug.rpy (7,074 bytes)
thaisi

thaisi

2018-06-07 06:25

reporter   ~0000479

I don't have any patches installed. I will try to dig up the necessary debug info for you. it is 100% reproducable, I restarted entire game from scratch (new save) and it still happened.
thaisi

thaisi

2018-06-10 07:00

reporter   ~0000481

In which folder should this `debug.rpy` be placed?

`Contents/MacOS/lib/darwin-x86_64/Lib?`

`Contents/Resources/autorun/renpy?`

`Contents/Resources/autorun/game?`

I was also checking https://www.renpy.org/doc/html/developer_tools.html for hints, but no avail.

And how do I get this console for info?
thaisi

thaisi

2018-06-10 07:01

reporter   ~0000482

I do have a save whilst i'm stuck in the minigame, but I don't know where the save files are to send them to you.
dogeek

dogeek

2018-06-10 12:29

developer   ~0000483

It may be an OS-related issue, as I've retested the minigame, and I'm not blocked in a loop whatsoever. Unfortunately, I don't own a mac to test it further (and I don't intend on buying an overpriced PC, sorry).

the debug.rpy file should be placed in the game folder in Summertime saga. Console is accessed with shift+o
thaisi

thaisi

2018-06-12 20:00

reporter   ~0000484

Ok it works when I place it in `Contents/Resources/autorun/game`
I can open the console or view the entire var dump (which is a huge list).

How can I output when in the guitarhero minigame the vars of this game?
thaisi

thaisi

2018-06-12 20:38

reporter   ~0000485

I see the print statements in the debug version of the class, but when I'm in the minigame the output is not shown in the console. Am I missing something? was the class override not working?
dogeek

dogeek

2018-06-13 01:48

developer   ~0000486

weird. I'll look this over to figure out what's wrong, the class should be overridden, and the prints should show up in the console.
thaisi

thaisi

2018-06-22 18:29

reporter   ~0000495

Any update?
thaisi

thaisi

2018-08-01 11:09

reporter   ~0000977

The issue is still there in 0.16.0 and 0.16.1
thaisi

thaisi

2018-08-02 11:43

reporter   ~0000994

It sucks I can now only complete the game in cheat mode because of this. I'm willing to help and investigate, if a Dev could assist me
thekinkyson

thekinkyson

2018-08-04 07:48

updater   ~0001020

Have been unable to reproduce on OSX.
Have played multiple times, with different numbers of notes missed, nothing has resulted in a never ending minigame.
thaisi

thaisi

2018-08-05 06:56

reporter   ~0001027

Hmm I noticed in the new version that stopping it is possible (esc key) this was not working before. I also did multiple clean runs deleting all my saves (didn't know where they were stored before) and now it seems working, after 25 notes passing it fails or succeeds. Because of the slow spawn rate it just takes quite a while.

self._DELAY_TO_SPAWN = 110 #1.10 s

if (clock() - self._start_time)*100 >= self._DELAY_TO_SPAWN:

self._DELAY_TO_SPAWN = random.randint(10, 12)*10

You would guess it would spawn every 1 to 1.2 seconds, but when clocking it, it spawns every 5 seconds or so.
therefor doing the minigame takes 2 minutes, while each other minigame in the game takes around 30 seconds.

I guess thats why I thought it was never ending.

The issue is resolved (that it it not neverending). It's the spawn rate that is really slow on mac somehow.

Issue History

Date Modified Username Field Change
2018-04-15 05:55 dipset12 New Issue
2018-04-16 21:18 GreenCap Note Added: 0000359
2018-05-01 21:38 thaisi Note Added: 0000451
2018-05-01 21:43 thaisi Note Added: 0000452
2018-05-03 17:16 thaisi Note Added: 0000455
2018-06-06 22:54 dogeek Note Added: 0000477
2018-06-06 23:01 dogeek File Added: debug.rpy
2018-06-06 23:01 dogeek Note Added: 0000478
2018-06-07 01:54 mil578 Relationship added related to 0000423
2018-06-07 06:25 thaisi Note Added: 0000479
2018-06-10 07:00 thaisi Note Added: 0000481
2018-06-10 07:01 thaisi Note Added: 0000482
2018-06-10 12:29 dogeek Note Added: 0000483
2018-06-12 20:00 thaisi Note Added: 0000484
2018-06-12 20:38 thaisi Note Added: 0000485
2018-06-13 01:48 dogeek Note Added: 0000486
2018-06-22 18:29 thaisi Note Added: 0000495
2018-08-01 11:09 thaisi Note Added: 0000977
2018-08-02 11:43 thaisi Note Added: 0000994
2018-08-02 13:14 GreenCap Status new => assigned
2018-08-04 07:48 thekinkyson Note Added: 0001020
2018-08-05 06:56 thaisi Note Added: 0001027
2018-11-27 04:30 mil578 Status assigned => resolved
2018-11-27 04:30 mil578 Resolution open => fixed