View Issue Details

IDCategoryLast Update
0001042Bug Report2018-12-13 03:53
Reporterhardango 
SeveritymajorReproducibilityalways
Status resolvedResolutionfixed
Summary0001042: Unable to open the game on Mac OS
DescriptionI had not played the recent update and just downloaded the most recent update for the Mac. I try to open the game however every time it says application not responding no matter what I do. I have tried it with nothing else running in the background. Not sure if its a bug but can't play the game.
Platform/OSOSX
Version0.16

Activities

hardango

hardango

2018-09-24 16:18

reporter  

dogeek

dogeek

2018-09-24 17:07

developer   ~0001180

It seems that it's because of the long load times, and there's a fix for that in the #help channel on the discord

0.17 will include this fix
hardango

hardango

2018-09-24 17:41

reporter   ~0001181

I am unable to get onto the discord channel how would I do so?
sam9

sam9

2018-09-24 18:19

administrator   ~0001182

1. Close any instances of the game
2. Download https://raw.githubusercontent.com/renpy/renpy/9e3149b9848d047aa3024b49b36c3cd35175a68e/renpy/common/00director.rpy
3. Put it in the renpy/common/ folder on PC/Linux, SummertimeSaga.app/Contents/Resources/autorun/renpy/common/ on Mac, overwriting the existing file
4. Start the game
diras2010

diras2010

2018-10-03 01:33

reporter   ~0001185

can confirm, tested on OS X High Sierra on an old 2010 Macbook Pro, the game takes a lot of time to launch

the proposed fix from sam9 works as intended, the game launches fine after the file is replaced

this can be set as solved / fixed

Issue History

Date Modified Username Field Change
2018-09-24 16:18 hardango New Issue
2018-09-24 16:18 hardango File Added: Screen Shot 2018-09-24 at 12.14.53 PM.png
2018-09-24 17:07 dogeek Note Added: 0001180
2018-09-24 17:08 dogeek Status new => resolved
2018-09-24 17:08 dogeek Resolution open => fixed
2018-09-24 17:41 hardango Status resolved => feedback
2018-09-24 17:41 hardango Resolution fixed => reopened
2018-09-24 17:41 hardango Note Added: 0001181
2018-09-24 18:19 sam9 Note Added: 0001182
2018-10-03 01:33 diras2010 Note Added: 0001185
2018-12-13 03:53 sam9 Status feedback => resolved
2018-12-13 03:53 sam9 Resolution reopened => fixed